About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.
Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.
Input Specification:
Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤105), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are considered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".
Then N lines follow, each gives the information of a person in the format:
ID_Number Virtue_Grade Talent_Grade
where ID_Number
is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.
Output Specification:
The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.
Sample Input:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
Sample Output:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
题目大意:
给定每个人的信息,分别为编号 id ,德行分数 virtue 和才华分数 talent 。
现在需要我们对给定的人进行排名,排名规则如下:
才华和德行均不低于 H 的是圣人,圣人们按德才总分不升序排序。
才华低于 H ,德行不低于 H 的是君子,君子们按德才总分不升序排序,他们都低于圣人。
才华和德行均低于 H ,但是德行不低于才华的是愚人,愚人们按德才总分不升序排序,他们都低于君子。
能够参与排名的,不属于以上三类人的均是小人,小人们按德才总分不升序排序,他们都低于愚人。
分析:总结一下排名规则,每种人均按照总分从高到低排名,总分相同则看德行分数从高到低,德行相同则看编号从小到大。
#include<algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <string>
#include <vector>
#include <cstdio>
#include <queue>
#include <stack>
#include <ctime>
#include <cmath>
#include <map>
#include <set>
#define ll long long
#define INF 0x3f3f3f3f
#define db1(x) cout<<#x<<"="<<(x)<<endl
#define db2(x,y) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<endl
#define db3(x,y,z) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<endl
using namespace std;
typedef struct people
{
int id,vg,tg,sum;
}people;
bool cmp(people a,people b)
{
if(a.sum!=b.sum)return a.sum>b.sum;
if(a.vg!=b.vg)return a.vg>b.vg;
return a.id<b.id;
}
int main(void)
{
#ifdef test
freopen("in.txt","r",stdin);
//freopen("in.txt","w",stdout);
clock_t start=clock();
#endif //test
int n,l,h,cnt=0;scanf("%d%d%d",&n,&l,&h);
vector<people>sage,nobleman,foolman,smallman;
people peo[n+5]={0};
for(int i=0;i<n;++i)
{
people temp;scanf("%d%d%d",&temp.id,&temp.vg,&temp.tg);
temp.sum=temp.vg+temp.tg;
if(temp.vg>=l&&temp.tg>=l)
{
cnt++;
if(temp.vg>=h&&temp.tg>=h)sage.push_back(temp);
else if(temp.vg>=h&&temp.vg>=temp.tg)nobleman.push_back(temp);
else if(temp.vg>=temp.tg)foolman.push_back(temp);
else smallman.push_back(temp);
}
}
printf("%d\n",cnt);
sort(sage.begin(),sage.end(),cmp);
sort(nobleman.begin(),nobleman.end(),cmp);
sort(foolman.begin(),foolman.end(),cmp);
sort(smallman.begin(),smallman.end(),cmp);
for(auto it=sage.begin();it!=sage.end();++it)
printf("%d %d %d\n",(*it).id,(*it).vg,(*it).tg);
for(auto it=nobleman.begin();it!=nobleman.end();++it)
printf("%d %d %d\n",(*it).id,(*it).vg,(*it).tg);
for(auto it=foolman.begin();it!=foolman.end();++it)
printf("%d %d %d\n",(*it).id,(*it).vg,(*it).tg);
for(auto it=smallman.begin();it!=smallman.end();++it)
printf("%d %d %d\n",(*it).id,(*it).vg,(*it).tg);
#ifdef test
clockid_t end=clock();
double endtime=(double)(end-start)/CLOCKS_PER_SEC;
printf("\n\n\n\n\n");
cout<<"Total time:"<<endtime<<"s"<<endl; //s为单位
cout<<"Total time:"<<endtime*1000<<"ms"<<endl; //ms为单位
#endif //test
return 0;
}