Bootstrap

辅音和元音字母数(python练习)

编写一个程序来计算给定单词中辅音字母和元音字母的数量。

  • 定义函数count_consonants(),参数为word。该函数应返回单词中辅音字母的数量。
  • 定义函数count_vowels(),参数为word。该函数应返回单词中元音字母的数量。

示例输入

Programming

示例输出

8

3

本题需要注意条件,判断辅音字母时还要判断该字符是否是字母。

def count_consonants(word):
    # 在此处编写你的代码
    re=0
    for ch in word:
        if ch.lower() not in ['a','e','i','o','u'] and ch.isalpha()==True:
            re+=1
    return re 

def count_vowels(word):
    # 在此处编写你的代码
    re=0
    for ch in word:
        if ch.lower() in ['a','e','i','o','u']:
            re+=1
    return re

# 获取用户输入
word = input()

# 调用函数
print(count_consonants(word))
print(count_vowels(word))
;