Bootstrap

文件操作--二进制文件读入

Problem A: 文件操作--二进制文件读入

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 88   Solved: 24
[ Submit][ Status][ Web Board]

Description

现有100名学生的姓名(name)、学号(num)、英语(English)、数学(Math)、语文(Chinese)成绩存储在一个二进制文件student.dic中(姓名用char[20],学号和各科成绩用int存储),现要求将指定行数的学生信息输出,每条信息占一行。

前5行学生信息为:
akdh 13773 84 83 66
fjka 30257 15 14 88
sfhklas 61281 87 8 31
hfu 38635 55 50 60
iwehfk 92803 54 6 77

Input

要输出行号的整数序列,以0作为结束标志。

Output

输出学生信息,每个学生占一行

Sample Input

1 3 5 0

Sample Output

akdh 13773 84 83 66
sfhklas 61281 87 8 31
iwehfk 92803 54 6 77

 
 
#include <iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
struct hehe{
char a[20];
int b,c,d,e;
};
int main()
{
     int n;
     hehe iii[101];
     FILE * fin;
     if ((fin= fopen ( "student.dic" , "rb+" ))==NULL)
     {
         printf ( "打开失败\n" );
         exit (-1);
     }
         fread (&iii[1], sizeof ( struct  hehe),100,fin);
     while (~ scanf ( "%d" ,&n)&&n!=0)
     {
  printf ( "%s %d %d %d %d\n" ,iii[n].a,iii[n].b,iii[n].c,iii[n].d,iii[n].e);
     }
     return 0;
}
;