poj 3094 Quicksum 水
Quicksum
Time Limit: 1000MS | Memory Limit: 65536K |
Total Submissions: 17095 | Accepted: 11865 |
Description
A checksum is analgorithm that scans a packet of data and returns a single number. The idea isthat if the packet is changed, the checksum will also change, so checksums areoften used for detecting transmission errors, validating document contents, andin many other situations where it is necessary to detect undesirable changes indata.
For this problem,you will implement a checksum algorithm called Quicksum. A Quicksum packetallows only uppercase letters and spaces. It always begins and ends with an uppercaseletter. Otherwise, spaces and letters can occur in any combination, includingconsecutive spaces.
A Quicksum is thesum of the products of each character's position in the packet times thecharacter's value. A space has a value of zero, while letters have a valueequal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Hereare example Quicksum calculations for the packets "ACM" and "MID CENTRAL":
ACM: 1*1 + 2*3 + 3*13 = 46
MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 +11*12 = 650
Input
The input consistsof one or more packets followed by a line containing only # that signals theend of the input. Each packet is on a line by itself, does not begin or endwith a space, and contains from 1 to 255 characters.
Output
For each packet,output its Quicksum on a separate line in the output.
Sample Input
ACM
MID CENTRAL
REGIONALPROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#
Sample Output
46
650
4690
49
75
14
15
代码:
//poj 3094Quicksum
#include <iostream>
#include <string>
usingnamespace std;
int main(int argc,charconst*argv[])
{
//freopen("in.txt","r", stdin);
string str;
while(getline(cin,str)&&(str[0]!='#')){
int sum=0;
for(int i=0; i<str.size(); i++){
if(str[i]==' ')continue;
sum+=(i+1)*(str[i]-'A'+1);
}
cout<< sum<< endl;
}
return0;
}