定义立方体类Box,数据成员有长宽高且都是整数,构造函数初始化数据成员,成员函数计算体积,主函数中输入长宽高,输出立方体体积。
输入格式:
输入立方体的长宽高,中间用空格分隔。
输出格式:
输出体积并换行。
样例">输入样例:
1 2 3
输出样例:
6
#include <iostream>
using namespace std;
class Box
{
private:
int length;
int wide;
int high;
int volume;
public:
void input()
{
cin>>length>>wide>>high;
}
void output()
{
volume=length*wide*high;
cout<<volume<<endl;
}
Box()
{
length=0;
wide=0;
high=0;
volume=0;
}
};
int main()
{
Box date1;
date1.input();
date1.output();
return 0;
}