Bootstrap

ACWING 842. 排列数字 (DFS)

给定一个整数 n,将数字 1∼n 排成一排,将会有很多种排列方法。

现在,请你按照字典序将所有的排列方法输出。

输入格式
共一行,包含一个整数 n。

输出格式
按字典序输出所有排列方案,每个方案占一行。

数据范围
1≤n≤7
输入样例:
3
输出样例:
1 2 3
1 3 2
2 1 3
2 3 1
3 1 2
3 2 1

https://www.acwing.com/problem/content/844/

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

typedef long long ll;
const int N=100010;

int path[N];
bool st[N];

void dfs(int u, int n) {

	if(u==n) {
		for(int i=0;i<n;i++) {
			cout<<path[i]<<" ";
		}
		cout<<"\n";
		return ;
	}

	for(int i=1;i<=n;i++) {
		if(!st[i]) {
			path[u]=i;
			st[i]=true;
			dfs(u+1,n);
			st[i]=false;
		}
	}
	return ;
}

int main() {
	//TODO
	int n;

	cin>>n;

	dfs(0,n);

	return 0;
}

;