Bootstrap

7-1 圆形体体积计算器 (20分) C++

题目

本题要求实现一个常用圆形体体积的计算器。计算公式如下:
1、球体体积 V=(4π/3)r^3,其中r是球体半径。
2、圆柱体体积 V=π
r^2*h,其中r是底圆半径,h是高。
3、圆锥体体积 V=(π/3)r^2h,其中r是底圆半径,h是高。

输入格式

在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

然后从标准输入读进一个整数指令。

输出格式

如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

  • 当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
  • 当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
  • 当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
    计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4 3
0

输出样例:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

代码

方法一:
用 if 语句完成

#include <iostream>
using namespace std;
#include<iomanip>
#define pi 3.1415926535
int main()
{
	int a;
	double r,V,h;
	while(1)
	{
	cout<<"1-Ball"<<endl;
	cout<<"2-Cylinder"<<endl;
	cout<<"3-Cone"<<endl;
	cout<<"other-Exit"<<endl;
	cout<<"Please enter your command:"<<endl;
	cin>>a;
		if(a==1)
		{
			cout<<"Please enter the radius:"<<endl;
			cin>>r;
			V=4*pi/3*r*r*r;
			cout<<setiosflags(ios::fixed)<<setprecision(2)<<V<<endl;
		}
		else if (a==2)
		{
			cout<<"Please enter the radius and the height:"<<endl;
			cin>>r>>h;
			V=pi*r*r*h;
			cout<<setiosflags(ios::fixed)<<setprecision(2)<<V<<endl;
		}
		else if (a==3)
		{
			cout<<"Please enter the radius and the height:"<<endl;
			cin>>r>>h;
			V=pi/3*r*r*h;
			cout<<setiosflags(ios::fixed)<<setprecision(2)<<V<<endl;
		}
		else break;
	}
	return 0;
}

方法二:
用switch语句完成

#include <iostream>
using namespace std;
#include<iomanip>
#define pi 3.1415926535
int main()
{
	int a;
	double r,V,h;
	cout<<"1-Ball"<<endl;
	cout<<"2-Cylinder"<<endl;
	cout<<"3-Cone"<<endl;
	cout<<"other-Exit"<<endl;
	cout<<"Please enter your command:"<<endl;
	cin>>a;
	while(a==1||a==2||a==3)
	{
	
		switch (a)
		{
		case 1:
		
			cout<<"Please enter the radius:"<<endl;;
			cin>>r;
			V=4*pi/3*r*r*r;
			cout<<setiosflags(ios::fixed)<<setprecision(2)<<V<<endl;
			break;
		case 2:
			
			cout<<"Please enter the radius and the height:"<<endl;
			cin>>r>>h;
			V=pi*r*r*h;
			cout<<setiosflags(ios::fixed)<<setprecision(2)<<V<<endl;	
			break;
			
		case 3:
			
			cout<<"Please enter the radius and the height:"<<endl;
			cin>>r>>h;
			V=pi/3*r*r*h;
			cout<<setiosflags(ios::fixed)<<setprecision(2)<<V<<endl;
			break;
			
		default :break;
	
		}
	cout<<"1-Ball"<<endl;
	cout<<"2-Cylinder"<<endl;
	cout<<"3-Cone"<<endl;
	cout<<"other-Exit"<<endl;
	cout<<"Please enter your command:"<<endl;
	cin>>a;
	}
	return 0;
}
;