时间限制: 1Sec 内存限制: 128MB 提交: 477 解决: 267
题目描述
回文串是从左到右或者从右到左读起来都一样的字符串,试编程判别一个字符串是否为回文串。
输入
输入一个字符串。串长度<255.
输出
判别输入的字符串是否为回文串,是输出"Y",否则输出"N"。
样例输入
abcba
样例输出
Y
#include <iostream>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;
int main()
{
string s1,s2;
cin>>s1;
s2=s1;
reverse(s1.begin(),s1.end());
if(s1==s2) puts("Y");
else puts("N");
return 0;
}