Bootstrap

回形取数C++

问题描述

回形取数就是沿矩阵的边取数,若当前方向上无数可取或已经取过,则左转90度。一开始位于矩阵左上角,方向向下。

输入格式

输入第一行是两个不超过200的正整数m, n,表示矩阵的行和列。接下来m行每行n个整数,表示这个矩阵。

输出格式

输出只有一行,共mn个数,为输入矩阵回形取数得到的结果。数之间用一个空格分隔,行末不要有多余的空格。

样例输入

3 3
1 2 3
4 5 6
7 8 9

样例输出

1 4 7 8 9 6 3 2 5
方法一:该方法超时

#include<bits/stdc++.h>
using namespace std;
int main(){
	int m,n,count;
	cin>>m>>n;
	count = m* n;
	int a[m][n];
	for(int i = 0;i < m;i++){
		for(int j = 0;j < n;j++){
			cin>>a[i][j];
		}
	}
	int f[m][n];
	int x = 0,y = 0;
	cout<<a[x][y]<<' ';
	f[x][y] = 1;
	while(count){
		while(x+1<m&&f[x+1][y]!=1){
			
			cout<<a[x+1][y]<<' ';
			count--;
			x++;
			f[x][y] = 1;
		
		}
		while(y+1<n && f[x][y+1]!=1){
			f[x][y+1] = 1;
			count--;
			y++;
			cout<<a[x][y]<<' ';
			
		}
		while(x-1>=0 && f[x-1][y]!=1){
			cout<<a[x-1][y]<<' ';
			count--;
			x--;
			f[x][y] = 1;
			
		}
		while(y-1>=0&& f[x][y-1]!=1){
			cout<<a[x][y-1]<<' ';
			count--;
			y--;
			f[x][y] = 1;
			
		}
	}
	return 0;
}

方法二:

#include<bits/stdc++.h>
using namespace std;
int main(){
	int m,n,count;
	cin>>m>>n;
	count = m*n;
	int a[m][n];
	for(int i = 0;i < m;i++){
		for(int j = 0;j < n;j++){
			cin>>a[i][j];
		}
	}
	int count1 = count;
	int b[count] = {0};
	int left = 0,top = 0,bottom = m-1,right = n-1;
	int k = 0;
	while(count){
		for(int i = top;i <= bottom;i++){
			b[k++] = a[i][left];
			count--;
		}
		left++;
		for(int i = left;i <= right;i++){
			b[k++] = a[bottom][i];
			count--;
		}
		bottom--;
		for(int i = bottom;i >= top;i--){
			b[k++] = a[i][right];
			count--;
		}
		right--;
		for(int i = right;i >=left;i--){
			b[k++] = a[top][i];
			count--;
		}
		top++;
	}
	for(int i = 0;i < count1;i++){
		cout<<b[i]<<' ';
	}
	return 0;
}
;