Bootstrap

handkerchief(数论)

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.

Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .

Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.

So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me “YES”, else tell me “POOR Haha”.
InputThere will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.OutputFor each input case, you should only the result that Haha can find the handkerchief or not.Sample Input
3 2
-1 -1
Sample Output
YES
题意:就是有n个人,然后有一个找箱子的规矩,每次找的时候,下一个必须和当前位置隔了m-1个人才可以,问他是否能够找到箱子;
解题思路:这道题时,一直没看懂题意,然后看咯别人的博客才知道这只是考察判断n与m是否互质的问题,如果互质就可以遍历每个人,否则不能。

#include <iostream>
#include <cstdio>
using namespace std;
long long gcd(long long a,long long b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    long long n,m;
    while(~scanf("%lld%lld", &n,&m))
        {
            if(n==-1&&m==-1) break;
            else
                {
                    if(gcd(n,m)==1) cout<<"YES"<<endl;
                    else cout<<"POOR Haha"<<endl;
                }
        }
    return 0;
}
;