6-1 Point类的运算 (10 分)
定义Point类,有坐标x,y两个私有成员变量;对Point类重载“+”(相加)、“-”(相减)和“==”(相等)运算符,实现对坐标的改变,要求用友元函数和成员函数两种方法实现。对Point类重载<<运算符,以使得代码
Point p; cout<<p<<endl;可以输出该点对象的坐标。
函数接口定义:
实现Point类。
裁判测试程序样例:
/* 请在这里填写答案 */
int main(int argc, char const *argv[])
{
Point p1(2,3);
cout<<p1<<endl;
Point p2(4,5);
cout<<p2<<endl;
Point p3 = p1+p2;
cout<<p3<<endl;
p3 = p2-p1;
cout<<p3<<endl;
p1 += p2;
cout<<p1<<endl;
cout<<(p1==p2)<<endl;
return 0;
}
输入样例:
无
输出样例:
在这里给出相应的输出。例如:
2,3
4,5
6,8
2,2
6,8
0
我的代码:
#include <iostream>
#include <string>
using namespace std;
class Point{
int x,y;
public:
Point(int a,int b){
x = a;
y = b;
}
Point operator+(const Point &point2){
return Point(x + point2.x,y + point2.y);
}
Point operator-(const Point &point2){
return Point(x - point2.x,y - point2.y);
}
void operator+=(const Point &point2){
x += point2.x;
y += point2.y;
}
bool operator==(const Point &point2){
if (x == point2.x && y == point2.y){
return true;
}
else
return false;
}
friend ostream& operator<<(ostream &out, Point &point){
out<<point.x<<","<<point.y;
return out;
}
};
int main()
{
Point p1(2,3);
cout<<p1<<endl;
Point p2(4,5);
cout<<p2<<endl;
Point p3 = p1+p2;
cout<<p3<<endl;
p3 = p2-p1;
cout<<p3<<endl;
p1 += p2;
cout<<p1<<endl;
cout<<(p1==p2)<<endl;
return 0;
}
6-2 车的不同行为 (10 分) 定义一个车(vehicle)基类,有虚函数Run、Stop等成员函数,由此派生出自行车(bicycle)类、汽车(motorcar)类,它们都有Run、Stop等成员函数。完成这些类使得主函数可以运行并得到正确的输出结果。
函数接口定义: 完成类代码
裁判测试程序样例:
/* 请在这里填写答案 */
int main(int argc, char const *argv[])
{
Vehicle veh;
Bicycle bic;
Motorcar mot;
run(veh);
run(bic);
run(mot);
return 0;
}
输入样例:
无
输出样例:
在这里给出相应的输出。例如:
Vehicle run
Bicycle run
Motorcar run
我的代码:
#include <iostream>
using namespace std;
class Vehicle{
public:
virtual void run(){
cout<<"Vehicle run\n";
}
};
class Bicycle:public Vehicle{
public:
virtual void run(){
cout<<"Bicycle run\n";
}
};
class Motorcar:public Vehicle{
public:
virtual void run(){
cout<<"Motorcar run\n";
}
};
void run(Vehicle &a){
a.run();
}
int main()
{
Vehicle veh;
Bicycle bic;
Motorcar mot;
run(veh);
run(bic);
run(mot);
return 0;
}
6-3 点和线段 (20 分) 已知表示点的类CPoint和表示线段的CLine类, 类CPoint包含:(1)表达点位置的私有数据成员x,y (2)构造函数及复制构造函数 类CLine包含: (1)两个CPoint的点对象(该两点分别为线段的两个端点) (2)构造函数(提示:构造函数中用初始化列表对内嵌对象进行初始化) (3)公有成员函数GetLen,其功能为返回线段的长度,返回值类型为整型 (4)类属性成员count用于记录创建的CLine类对象的个数,及用于显示count值的ShowCount函数; 要求: (1)实现满足上述属性和行为的CPoint类及CLine类定义; (2)保证如下主函数能正确运行。
裁判测试程序样例:
/* 请在这里填写答案 */
int main(){
int x,y;
cin>>x>>y;
CPoint p1(x,y);
cin>>x>>y;
CPoint p2(x,y);
CLine line1(p1,p2);
cout<<"the length of line1 is:"<<line1.GetLen()<<endl;
CLine line2(line1);
cout<<"the length of line2 is:"<<line2.GetLen()<<endl;
cout<<"the count of CLine is:"<<CLine::ShowCount()<<endl;
return 0;
}
输入样例:
在这里给出一组输入。例如:
1 1
4 5
输出样例:
在这里给出相应的输出。例如:
The length of line1 is:5
The length of line2 is:5
The count of Line is:2
我的代码:
#include <iostream>
#include <string>
#include <cmath>
using namespace std;
/* 请在这里填写答案 */
class CPoint{
int x,y;
public:
CPoint(){
x = 0;
y = 0;
}
CPoint(int a,int b){
x = a;
y = b;
}
CPoint(const CPoint &obj){
x = obj.x;
y = obj.y;
}
int getx(){
return x;
}
int gety(){
return y;
}
};
class CLine:public CPoint{
CPoint p1,p2;
static int count;
public:
CLine(const CLine &l){
p1 = l.p1;
p2 = l.p2;
count++;
}
CLine(CPoint a,CPoint b){
p1 = a;
p2 = b;
count++;
}
int GetLen(){
return sqrt(pow(p1.getx()-p2.getx(),2) + pow(p1.gety()-p2.gety(),2));
}
static int ShowCount(){
return count;
}
};
int CLine::count = 0;
int main(){
int x,y;
cin>>x>>y;
CPoint p1(x,y);
cin>>x>>y;
CPoint p2(x,y);
CLine line1(p1,p2);
cout<<"the length of line1 is:"<<line1.GetLen()<<endl;
CLine line2(line1);
cout<<"the length of line2 is:"<<line2.GetLen()<<endl;
cout<<"the count of CLine is:"<<CLine::ShowCount()<<endl;
return 0;
}
7-1 运算符重载 (10 分) 请定义一个分数类,拥有两个整数的私有数据成员,分别表示分子和分母(分母永远为正数,符号通过分子表示)。 重载运算符加号"+",实现两个分数的相加,所得结果必须是最简分数。
输入: 第一行的两个数 分别表示 第一个分数的分子和分母(分母不为0)。 第二行的两个数 分别表示 第二个分数的分子和分母。
输出: 第一个数表示分子,第二个数表示分母(若分数代表的是整数,则不输出分母)。
输入:
第一行的两个数 分别表示 第一个分数的分子和分母(分母不为0)。 第二行的两个数 分别表示 第二个分数的分子和分母。
输出:
第一个数表示分子,第二个数表示分母(若分数代表的是整数,则不输出分母)。
输入样例:
1 5
2 5
输出样例:
3 5
收获:
1.约分分数的好方法(转载自ataraxy_thinking):
/*分数化简,关键是求出分母和分子的最大公因数。
这里采用“辗转相除法”求两个整数的最大公因数。
辗转相除法, 又名欧几里德算法(Euclidean algorithm),是求最大公约数的一种方法。
它的具体做法是:用较大数除以较小数,再用出现的余数(第一余数)去除除数,再用出现的余数(第二余数)去除第一余数,
如此反复,直到最后余数是0为止。如果是求两个数的最大公约数,那么最后的除数就是这两个数的最大公约数。
*/
#include<iostream>
using namespace std;
int main() {
int n, m;
cout << "请分别输入分母和分子:" << endl;
cin >> m >> n;
int m0 = m, n0 = n; //m0和n0保存m和n的原始值
while (m%n != 0) {
int temp = m ;
m = n;
n = temp%n;
}
cout << "原分式的最简分式为: " << n0 / n << "/" << m0 / n << endl;
}
区分大小的情况如下:
int a = t.A, b = t.B;
while (a % b != 0)
{
int temp = a;
a = b;
b = temp % b;
}
int m = (abs(a) < abs(b) ? a : b);
t.A /= m;
t.B /= m;
2.要注意分子等于0的情况!
我的代码:
#include <iostream>
using namespace std;
class Fraction{
int son,mon;
public:
Fraction(){};
Fraction(int x,int y){
son = x;
mon = y;
}
Fraction operator+(Fraction &obj){
Fraction f;
f.mon = mon * obj.mon;
f.son = son * obj.mon + obj.son *mon;
int a = f.son;
int b = f.mon;
if (a == 0){
return f;
}
while (a % b != 0)
{
int temp = a;
a = b;
b = temp % b;
}
int m = (abs(a) < abs(b) ? a : b);
f.son /= m;
f.mon /= m;
return f;
}
Fraction(const Fraction &obj){
son = obj.son;
mon = obj.mon;
}
int getson(){
return son;
}
int getmon(){
return mon;
}
};
int main(){
int a,b;
cin>>a>>b;
Fraction f1(a,b);
cin>>a>>b;
Fraction f2(a,b);
Fraction f3(f1 + f2);
if (f3.getmon() != 1 && f3.getson() != 0) {
printf("%d %d", f3.getson(), f3.getmon());
}
else
cout<<f3.getson();
}
7-2 类的继承与派生 (25 分)
定义平面二维点类CPoint,有数据成员x坐标,y坐标,函数成员(构造函数复制构造函数、虚函数求面积GetArea,虚函数求体积函数GetVolume、输出点信息函数print。由CPoint类派生出圆类Cirle类(新增数据成员半径radius),函数成员(构造函数、复制构造函数、求面积GetArea,虚函数求体积函数GetVolume、输出圆信息函数print。 再由Ccirle类派生出圆柱体Ccylinder类(新增数据成员高度height),函数成员(构造函数、复制构造函数、求表面积GetArea,求体积函数GetVolume、输出圆柱体信息函数print。在主函数测试这个这三个类。
输入格式:
0 0 例如:第一行读入圆心坐标。 1 2 第二行读入半径与高度。
输出格式:
分四行输出,分别代表圆心、底面积、表面积、体积。
输入样例:
在这里给出一组输入。例如:
0 0
1 2
输出样例:
在这里给出相应的输出。例如:
Center:(0,0)
radius=1
height:2
BasalArea:3.14159
SupfaceArea:18.8496
Volume:6.28319
别人的代码(转自Here):
#include <iostream>
#include <math.h>
#define PI 3.1415926
using namespace std;
//点
class CPoint{
double X,Y;
public:
CPoint(double x,double y);
CPoint(CPoint &cP);
virtual double GetArea(){}//求面积
virtual double GetVolume(){}//求体积
void print();
};
CPoint::CPoint(double x,double y):X(x),Y(y){}
CPoint::CPoint(CPoint &cP):X(cP.X),Y(cP.Y){}
void CPoint::print(){ cout<<"Center:("<<X<<","<<Y<<")"<<endl; }
//圆
class Cirle :public CPoint{
double Radius;
public:
Cirle(double x,double y,double r);
Cirle(Cirle& c);
double GetRadius(){ return Radius; }
double GetArea();//求面积
virtual double GetVolume();//求体积
void print();
};
Cirle::Cirle(double x,double y,double r):CPoint(x,y),Radius(fabs(r)){}
Cirle::Cirle(Cirle& c):CPoint(c),Radius(c.Radius){}
double Cirle::GetArea(){ return PI*Radius*Radius; }
double Cirle::GetVolume(){ return 3*PI*Radius*Radius*Radius/4; }
void Cirle::print(){ cout<<"radius="<<GetRadius()<<endl; }
//圆柱
class Ccylinder :public Cirle{
double Height;
public:
Ccylinder(double x,double y,double r,double h);
Ccylinder(Ccylinder &cc);
double GetHeight(){ return Height; }
double GetArea();//求面积
virtual double GetVolume();//求体积
void print();
};
Ccylinder::Ccylinder(double x,double y,double r,double h):Cirle(x,y,r),Height(fabs(h)){}
Ccylinder::Ccylinder(Ccylinder& cc):Cirle(cc),Height(cc.Height){}
double Ccylinder::GetArea(){ return PI*GetRadius()*GetRadius(); }
double Ccylinder::GetVolume(){ return PI*GetRadius()*GetRadius()*Height; }
void Ccylinder::print(){
cout<<"height:"<<GetHeight()<<endl;
cout<<"BasalArea:"<<GetArea()<<endl;
cout<<"SupfaceArea:"<<(2*GetArea()+2*PI*GetRadius()*Height)<<endl;
cout<<"Volume:"<<GetVolume()<<endl;
}
int main(){
double x,y,r,h;
cin>>x>>y>>r>>h;
CPoint cp(x,y);
Cirle c(x,y,r);
Ccylinder cc(x,y,r,h);
cp.print();
c.print();
cc.print();
return 0;
}