Bootstrap

Nise-Anti-AK Problem

计蒜客2018 ACM-ICPC 中国大学生程序设计竞赛线上赛L.Nise-Anti-AK Problem
Description:

Peppa has been learning math recently, he is trapped by a easy problem. He is given a sequence of n numbers, what he need to do is finding the number ai which have the largest number f(ai). The function f(x)=∑(i|x) where i goes form 0 to x, | is the symbol of or-by-bit calculate.

Input:

The first line of the input has an integer T(1<=T<=10), which represents the number of test cases.

In each test case, the first line of the input contains an integers n(1<=n<=1000)–the number of the integers, next line has n integers a[i] (1 <= a[i] <= 10000).

Output:

Each test case output an integer ai which have the largest number f(ai).

忽略每行输出的末尾多余空格
样例输入

1
3
2 3 5
样例输出

5
题意:
f(x)=∑(i|x)(i是从0到x)
从0到x与x的位运算 | 的加和
给一个数组,判断最大的f(a[i])并输出对应的a[i]
AC代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int t;
    int a[1010];
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        int imax = 0;
        int re;
        for(int i = 0; i < n; i++)
        {
            cin>>a[i];
            int ans = 0;
            for(int j = 0; j <=a[i]; j++)
            {
                ans += (j | a[i]);
            }
            if(imax < ans)
            {
                imax = ans;
                re = a[i];
            }

       }

        cout<<re<<endl;
    }

    return 0;
}
;