Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:
Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
Input Specification:
Each input file contains one test case, which gives a positive N (≤10^5) followed by a permutation sequence of {0, 1, ...,N−1}. All the numbers in a line are separated by a space.
Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9
#include <stdio.h>
int main() {
int i, t, n, a[100000];
int circle = 0, flag = 0, count = 0;
scanf("%d", &n);
for (i = 0;i < n;i++)
scanf("%d", &a[i]);
if (a[0] == 0)
flag = 1; //判断0是否在某一个环内
for (i = 0;i < n;i++) {
if (a[i] != i){
circle++; //环的数量(不包括仅有一个元素的环)
while (a[i] != i) {
t = a[i];
a[i] = i;
i = t;
count++; //所有环的元素数量和
}
}
}
if (flag) printf("%d", circle + count);
else printf("%d", circle - 1 + count - 1);
return 0;
}