Bootstrap

11-散列2 Hashing (25分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key) = key \% TSizeH(key)=key%TSize where TSizeTSizeis the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSizeMSize (\le 10^4104) and NN (\le MSizeMSize) which are the user-defined table size and the number of input numbers, respectively. Then NN distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 10000
typedef struct HTable *HashTable;
struct HTable {
	int *list;
	int size;
};
HashTable CreatTable(int n);
int Insert(HashTable H, int num);
int NextPrime(int n);

int main() {
	int i, m, n, num;
	int pos[N];
	HashTable H;
	scanf("%d%d", &m, &n);
	H = CreatTable(m);
	for (i = 0; i < n; i++) {
		scanf("%d", &num);
		pos[i] = Insert(H, num);
	}
	if (n) {
		printf("%d", pos[0]);
		for (i = 1; i < n; i++) {
			if (pos[i] == -1) printf(" -");
			else printf(" %d", pos[i]);
		}
	}
	return 0;
}

HashTable CreatTable(int n) {
	HashTable H;
	int i;
	H = (HashTable)malloc(sizeof(struct HTable));
	H->size = NextPrime(n);
	H->list = (int*)malloc(H->size*sizeof(int));
	for (i = 0; i < H->size; i++)
		H->list[i] = 0;
	return H;
}



int Insert(HashTable H, int num) {
	int pos, i;
	pos = num % H->size;
	for (i = 0; i <= H->size/2 && H->list[pos]; i++) //增量 <= size/2
		pos = (pos + 2 * i + 1) % H->size;	
	if (i <= H->size/2) {
		H->list[pos] = 1;
		return pos;
	}
	else return -1;
}

int NextPrime(int n) {
	int i, j;
	if (n == 1 || n % 2 == 0) //1不是素数
		n++;
	for (i = n;; i += 2) {
		for (j = 3; j*j <= i && i%j; j++);
		if (j*j > i) break;
	}
	return i;
}



;