Bootstrap

PTA - 身体质量指数(高教社,《Python编程基础及应用》习题6-3

身体质量指数(英文为Body Mass Index,简称BMI),其值为体重除以身高的平方。体重单位为千克,身高
单位为米。BMI是目前国际上常用的衡量人体胖瘦程度以及是否健康的一个标准。下面是16岁以上人群的BMI图
表:

BMI解释
BMI<18超轻
18<=BMI<25标准
25<=BMI<27超重
27<=BMI肥胖

编写一个程序,输入用户的体重(Kg)和身高(米),显示其BMI值,并作出解释性评价。

输入格式:

体重,身高

输出格式:

超轻/标准/超重/肥胖之一。

输入样例:

70,1.75

输出样例:

标准

我的答案:

这个题没啥好方法,按照题意模拟就行了~

weight, height = map(float, input().split(","))
stand = weight / (height ** 2)

if (stand < 18):
    print("超轻")
elif (18 <= stand and stand < 25):
    print("标准")
elif (25 <= stand and stand < 27):
    print("超重")
else:
    print("肥胖")

;