Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45
题目大意:N表示月饼种类,D表示月饼的市场最大需求量,给出每种月饼的数量和总价,问这些月饼的最大销售利润为多少。
分析:首先根据月饼的总价和数量计算出每一种月饼的单价,然后将月饼数组按照单价从大到小排序,遍历整个数组,每次查看当前的这种月饼是否能全部卖掉,若能,则直接加上它的总价;若不能,按照单价去计算还能卖出多少利润。
注意每种月饼的数量也需要是浮点类型,用整型的话会出错。
#include <cmath>
#include <ctime>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define ll long long
#define db1(x) cout<<#x<<"="<<(x)<<endl
#define db2(x,y) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<endl
#define db3(x,y,z) cout<<#x<<"="<<(x)<<", "<<#y<<"="<<(y)<<", "<<#z<<"="<<(z)<<endl
typedef struct mooncake
{
double price,ave,cnt;
}mooncake;
bool cmp(mooncake a,mooncake b)
{
return a.ave>b.ave;
}
int main(void)
{
#ifdef test
freopen("in.txt","r",stdin);
//freopen("in.txt","w",stdout);
clock_t start=clock();
#endif //test
int n,d;scanf("%d%d",&n,&d);
mooncake mc[n];
for(int i=0;i<n;++i)
scanf("%lf",&mc[i].cnt);
for(int i=0;i<n;++i)
scanf("%lf",&mc[i].price),mc[i].ave=mc[i].price*1.0/mc[i].cnt;
sort(mc,mc+n,cmp);
int t=0;
double ans=0.0;
while(d>0&&t<n)
{
double temp=d;
d=max(0.0,d-mc[t].cnt);
ans+=(temp-d)*mc[t++].ave;
}
printf("%.2f\n",ans);
#ifdef test
clockid_t end=clock();
double endtime=(double)(end-start)/CLOCKS_PER_SEC;
printf("\n\n");
cout<<"Total time:"<<endtime<<"s"<<endl; //s为单位
cout<<"Total time:"<<endtime*1000<<"ms"<<endl; //ms为单位
#endif //test
return 0;
}