Bootstrap

浙大数据结构慕课课后题(02-线性结构3 Reversing Linked List)

题目要求:

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

输入格式:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next 

where Address is the position of the node, Data is an integer, and Next is the position of the next node. 

输出格式: 

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input. 

 样例输入:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

样例输出: 

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1 

题目翻译:

题解: 

        思路如注释所示,可通过所有测试点。

#include<bits/stdc++.h>

using namespace std;

struct Node{
	int address;
	int data;
	int next;
};

int main(){
	int start,N,K;
	cin>>start>>N>>K;
	
	const int MAXN = 100000;
	Node nodes[MAXN]; //存储所有节点
	int result[MAXN]; //存储逆序后的链表地址
	
	for(int i=0;i<N;i++){
		int address,data,next;
		cin>>address>>data>>next;
		nodes[address] = {address,data,next};
	} 
	
	//重新构造链表 
	int count = 0;
	int current = start;
	while(current != -1){
		result[count++] = current;
		current = nodes[current].next;		
	}
	
	//进行链表逆转
	//直接交换链表的地址值进行逆置 
	for(int i = 0;i+K <= count;i += K){
		for(int j = 0;j<K/2;j++){
			int tmp = result[i+j];
			result[i+j] = result[i+K-1-j];
			result[i+K-1-j] = tmp;   	
		} 
	}
	
	//输出结果
	for(int i=0;i<count;i++){
		int address = result[i];
		int data = nodes[address].data;
		int next = (i!=count-1) ? result[i+1]:-1;
		
		printf("%05d %d ",address,data);
		if(next == -1)
			printf("-1\n");
		else
			printf("%05d\n",next);
	}
	 
	return 0;
} 

关于此题注意要点:

        1. 对链表的存储,使用了结构数组的方法,这样可以直接存储并操作其地址,这样我们在进行逆转时直接交换两个节点的地址即可。

        2.使用result数组对链表中的元素进行一个有序的存储,这样可以在交换个别节点地址时保证链表本身的有序性。

闲谈:

        因为我本身不是专业参加竞赛选手,自己编码能力暂时有限,我本身想用陈姥姥上课方法实现此题。理解了她讲的大概思路,但是总是细节处理不当,也没有找到很清晰的题解,故而换了一种思路求解,可能实现过程更加简单一点,也能解出来题,但是对编码能力锻炼不强,点到即止吧。(上周发烧停更了一周,有些懈怠,痛定思痛继续打卡)

        咳咳项目突然催进度了,等我把数据库学完再回归:( 

;