本题要求编写一个解密英文藏头诗的程序。建议使用动态内存分配方法处理字符串的输入。
输入格式:
输入为一首英文藏头诗,每句一行,小于20行,每行不超过80个字符,以#作为藏头诗的输入结束标志。
输出格式:
取出每句的第一个字符,连接在一起形成一个字符串并输出。
输入样例:
I come into a dream
Leaves fall down but spring
over a lake birds flying
village have its nice morning
everywhere can feel happiness
Years have never been
owners don't need anything
until the sun bring another wind
#
输出样例:
ILoveYou
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
char *p[20];
char c[81];
int i=0,n,j;
gets(c);
while(strcmp(c,"#")!=0)
{
n=strlen(c);
p[i]=(char*)malloc(n*sizeof(char)+1);
strcpy(p[i],c);
i++;
gets(c);
}
for(j=0;j<i;j++)
c[j]=*p[j];
c[j]='\0';
puts(c);
for(j=0;j<i;j++)
free(p[j]);
return 0;
}