Bootstrap

Point类的构造函数(JAVA)

Problem Description
通过本题目的练习可以掌握类的构造函数的定义;

设计一个点类Point,私有数据成员有x、y;公有成员函数有:无参数的构造函数Point(),带参数的构造函数Point(int,int);ShowPoint()输出点对象的信息

在主函数main()中调用相应成员函数,从键盘接收时间对象的x和y的值,并向显示器输出相应的值。

Input

输入2个整数,用一个空格间隔

Output

要求先输出默认的点值,再输出用户构造的点的值

点的格式为:一对圆括号内 x,y的值,中间用“,”间隔;

Sample Input
10 11
Sample Output
(0,0)
(10,11)

import java.util.Scanner;

class Point{
    int x, y;

    public Point() {
        super();
        System.out.println("(" + this.x + "," + this.y + ")");
    }

    public Point(int x, int y) {
        super();
        this.x = x;
        this.y = y;
        System.out.println("(" + this.x + "," + this.y + ")");
    }

}


public class Main {
        public static void main(String[] args){
            Scanner cin = new Scanner(System.in);
            int x, y;
            x = cin.nextInt();
            y = cin.nextInt();
            Point point = new Point();
            point = new Point(x,y);
            cin.close();
        }
}
;