Bootstrap

PTA 7-2 把字符串中的所有字符按从小到大的顺序排序

输入一个字符串,把字符按从小到大的顺序排序后输出。

输入格式:
输入一个长度不超过20的字符串。

输出格式:
把字符按从小到大的顺序排序后输出。

输入样例:
在这里给出一组输入。例如:

defgacb

输出样例:
在这里给出相应的输出。例如:

abcdefg

代码:

#include <stdio.h>
#include <string.h>
int main() {
	char s[99],s1[99];
	gets(s);
	int i,t;
	char n;
	for (i = 0; s[i] != '\0'; i++) {
		for (t = 0; s[t] != '\0'; t++) {
			if (s[i] < s[t]) {
				n = s[t];
				s[t] = s[i];
				s[i] = n;
			}
		}
	}
	puts(s);
	return 0;
}

可以的话请给个赞,谢谢

;