输入格式:
输入首先给出正整数N(≤10 ^5),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。
输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。
输入样例:
4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
输出样例:
13588625832 3
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 12
typedef struct ListNode *Position;
typedef struct HTable *HashTable;
struct ListNode {
char data[N];
int count;
Position next;
};
struct HTable {
Position list;
int size;
};
HashTable CreatTable(int n);
void Insert(HashTable H, char *key);
void Solve(HashTable H);
int NextPrime(int n);
int main() {
int i, n;
char key[N];
HashTable H;
scanf("%d", &n);
H = CreatTable(n * 2);
for (i = 0; i < 2 * n; i++) {
scanf("%s", key);
Insert(H, key);
}
Solve(H);
return 0;
}
HashTable CreatTable(int n) {
HashTable H;
int i;
H = (HashTable)malloc(sizeof(struct HTable));
H->size = NextPrime(n);
H->list = (Position)malloc(H->size*sizeof(struct ListNode));
for (i = 0; i < H->size; i++)
H->list[i].next = NULL;
return H;
}
void Insert(HashTable H, char *key) {
Position p, temp;
int h;
h = (atoi(key + 6)) % H->size;
p = H->list[h].next;
while (p && strcmp(p->data, key)) {
p = p->next;
}
if (p) p->count++;
else {
temp = (Position)malloc(sizeof(struct ListNode));
strcpy(temp->data, key);
temp->count = 1;
temp->next = H->list[h].next;
H->list[h].next = temp;
}
}
void Solve(HashTable H) {
int i, max = 0, num;
char min[N];
Position p;
for (i = 0; i < H->size; i++) {
p = H->list[i].next;
while (p) {
if (p->count > max) {
max = p->count;
strcpy(min, p->data);
num = 1;
}
else if (p->count == max) {
num++;
if (strcmp(p->data, min) < 0)
strcpy(min, p->data);
}
p = p->next;
}
}
if(num == 1)
printf("%s %d\n", min, max);
else
printf("%s %d %d\n", min, max, num);
}
int NextPrime(int n) {
int i, j;
n = (n % 2) ? n + 2 : n + 1;
for (i = n;; i += 2) {
for (j = 3; j*j <= i && i%j; j++);
if (j*j > i) break;
}
return i;
}