Bootstrap

【例3.4】适合晨练 ------ 信息学奥赛高级题库

【题目描述】

输入温度t的值,判断是否适合晨练。(25≤t≤30,则适合晨练ok!,否则不适合no!)

【输入】

输入温度t的值。

【输出】

输出判断结果

【输入样例】

26

【输出样例】

ok!

解法一

#include <iostream>

using namespace std;

int main() {
    int t;
    cin>>t;
    t>=25&&t<=30?cout<<"ok!":cout<<"no!";
}

解法二

#include <iostream>

using namespace std;

int main() {
    int t;
    cin>>t;
    if(t>=25 && t<=30)
        cout<<"ok!";
    else
        cout<<"no!";
}
;